Remote Desktop Tips and Tricks

I also have the same problem as Alfred. I have dual monitors at work but only a single wide screen monitor at home. I leave Outlook open on my second monitor so when I log in I have no way to get to that monitor to see my email. How do we get to the second monitor?

Hi there,

I am having problems with using Remote desktop that you might be able to help me with.

I can connect from my laptop to my media centre machine using remote desktop. But my TV on my media centre goes blank. I cannot now, after disconnecting the laptop from remote desktop, get the TV to work. It seems to have reset the resolution. How can i reverse what the remote desktop has done

Many thanks

Mark Wiltshire

args, i have to use a rdp client tool on a machine that have a resulotion of 3072x768 and the windows xp client only support 1600x1200. redesktop on unix can more, so it is not a problem of the server. does anyone have another application running but using rdp ?


Nice site. Regarding multiple monitors - check iShadow Desktop -

Along with RDP the app supports even ICA and VNC.

Vista Remote Desktop now has dual monitor support, see

And the last comment contains the link to the Vista RDC software required


Note that the link above has an extra space in it that you need to remove, this blog censor wouldn’t let me post the link otherwise, odd.

New version of remote desktop released-- supports multiple monitors, 32-bit color, font smoothing, and higher resolutions. Sweet.

Please help - I have setup a HTPC which is connected to my TV to play music and video. I had to remove the PC monitor and now I use remote desktop to connect to it.

Music works fine but I can’t get the TV out of my ATI 9200 graphics card to output to the TV any more. It just displays the log in (or screensaver) that usually appears on the remote PC.

Is controlling the PC via RDesktop possible whilst allowing the TV out to play DVDs? I previously could just swap between monitors to push the video signal out of the S-Video jack.

It would be a tad painful if I had to again connect a monitor up and again clutter up the entertainment system!


Just trying to get a saved .rdp connection to remember to goto my second monitor at full screen. Using the latest RDP client from MSoft…

But for the life of me I can’t get it to remember to goto the other monitor. Used the trick above, but it continues to goto the primary at full screen…

Any ideas?

I also use multiple monitors and tried to get it to “stick” full screen to a different monitor - no luck.

did anyone resolve the widescreen RDP issue or solve why some can and some can’t. We have 2 servers which are accessed via RDP on widescreen one appears to work ok with widescreen, put it to full screen on RDP and it works no problem, the other, doesn’t seem to want to play. both Dell PE servers, dell pc’s btw.



Is there any way to use RD without it locking the client machine. I am wanting the client to be able to watch what I am doing and/or show me what is happening to them. I do not however want to do this using remote assistance as this is too much of a hastle. Thanks…

To make Vista RDP go full screen on a second monitor…

add step 2.5: before closing the windows rdp session, un maximize the window.

i noticed that even though it was windowed, it was “maximized”.

My multiple monitor solution:

Simply awesome.



I use a single monitor at home and RD to amy work XP pro system which has dual monitors. If i could just bring up the remote’s Display Properties dialog and on the Setings Tab swtich the remote back to single monitor it would be great.

Also, to whoever said they remote from A-B and then from B-C Jeff responded (paraphrasing here)“its time to ask yourself why?” Well I do that also and the reason is: only PC_B is allowed to cross the firewall to PC_C so to access PC_C from my home PC_A i have to go A-B-C no other way around it

Biggest Problem: Is there any way to control which shortcuts are intercepted by RDC in full-screen mode? I want Ctrl-TAB to cycle through the list of windows on the RDC connection, but I want Alt-2, Alt-3, to cycle to other local Virtual desktops.

So far, I’ve had to give up Ctrl-Tab within my remote desktops, for the privilege of mixing full-screen local and remote desktops.

Biggest Solution: Shutdown and/or Reboot. Somehow, the Windows Security menu is a well-kept secret. I have known people who wrote programs to reboot a remote machine. All you have to do is start the Windows Security menu, either from the Start Menu, or using the Ctrl-Alt-End shortcut this article just taught me. You then have all the Ctrl-Alt-Del menu choices at your home away from home.

Had the same widescreen problem (using my Dell 22" 1680x1050). Remote Desktop Connection 6.0 client update ( fixes this issue.

When launching the new client, before you hit the Connect button, click "Options " and then “Display” tab. Here you can choose your choice of resolution that your local widescreen monitor supports well or Full Screen. Enjoy your server with the Big and Wide screen!

Thanks to the tips from SharpStyle!

Excellent. Thank you. My RD would’nt go fullscreen anymore :slight_smile: Now it does…

This is a bit of a pain and not nearly perfect, but here’s a way to get a remote desktop session to span multiple monitors of different sizes:

1) Invoke remote desktop with the width and height arguments instead of span.  Set the width to the combined width of your monitors, and set the height to the smallest monitor's height.  For example, if one monitor 1280 x 1024 and the other is 1600 x 1200, use the following on the command line:

mstsc.exe /W:2880 /H:1000 path-to-your-rdp
  • You might notice this is actually a little shorter than it could be. In my setup, the smaller monitor is where I keep the taskbar, so this is to account for the taskbar’s height on the local system.

    1. If the session came up maximized, un-maximize it.

    2. stretch the window to it’s full size and position it to fill the smaller monitor from top to bottom. It should fill the width of the larger screen and some portion of the height.

This has several limitations:

  • It requires the Remote Desktop Connection 6.0 client.
  • It doesn’t allow you the option of choosing “Apply Windows key combinations in Full Screen only”.
  • The point where your two monitors meet is not in the middle, so software like SplitView or GridVista don’t work as well.
  • You can’t easily save this setup. You basically have to do the whole “stretch and reposition” exercise every time. (You can make a shortcut to mstsc.exe that passes in your arguments.)

How do I remove the x from the connection bar of the RDC. I want to display my application only and force the user to log out of the app, not click the x on the connection bar.