You just beat me to it.
Good method naming is great for people calling your code. For people actually maintaining your code, all naming is important. Method, variable, class, etc names should all be descriptive.
If there isn't a clear name for an entity, there's a very good chance that it shouldn't exist in the first place.
One good example is loop counters. How many times have you seen for(int i = 0; i some_number; i++), when there is actually a meaning to the loop counter, such as an array index, or something_count?
By all means, keep code terse, but not to the point of obfuscation. FFS, a couple bytes of extra code for clarity is great value.